macOS 10.15 Catalina innebär det definitiva slutet på alla gamla 32-bitars program. Från och med den här versionen av macOS så finns inget inbyggt stöd kvar för den gamla sortens program.

Har du inget val utan måste kunna köra ett 32-bitars program så finns det fortfarande en del olika lösningar – förutom det uppenbara att inte uppdatera till macOS Catalina. Du kan köra macOS Mojave virtuellt och använda den gamla versionen av macOS för att kunna köra gamla program. Det ska tilläggas att det inte är en enkel eller ens smidig lösning men den fungerar.

Varning

 Tidigare, i macOS Mojave, så fick du en varning när du startade 32-bitars program och en uppmaning att uppdatera programmet till en nyare version.

Nu är meddelandet och dialogrutan mer direkt. Nu sägs det att programmet måste uppdateras.

Du kan själv kontrollera om dum har några 32-bitars program installerade – antingen direkt i katalogen med dina program. är ikonen grå med ens streck över så är det ett 32-bitars program som du inte kan starta. Ett annat sätt är att gå till ”äpplet” om denna Mac, starta systeminformationen och sedan gå till Appplications och lista dina program. Står det nej i sista kolumnen så är det ett 32-bitars program.

2012

Program från 2011-2012 eller äldre är sannolikt gamla, 32-bitars program. De kan du alltså inte använda längre ich har du uppdaterat till Catalina så finns ingen återvändo – såvida du inte ätervänder till Mojave.