macOS High Sierra är sista operativsystemet som stöder 32-bitars program

macOS High Sierra är sista operativsystemet som stöder 32-bitars program

macOS High Sierra är sista operativsystemet som stöder 32-bitars program

iOS 11 blir det definitiva slutet för 32-bitars appar. De kommer helt enkelt inte att fungera. macOs High Sierra blir också det sista operativsystemet som fortfarande har stöd för 32-bitars program.

Från och med iOS 11 så är det alltså slut med de gamla apparna på iOS.

Nu har Apple gått med samma besked för macOS som Apple gjorde 2013 gällande iOS:

“If you distribute your apps outside the Mac App Store, we highly recommend distributing 64-bit binaries to make sure your users can continue to run your apps on future versions of macOS.”

Nedräkningen

Det innebär att nedräkningen startar även när det gäller macOS. Nästa version High Sierra blir alltså den sista versionen där du kommer att kunna köra den äldre typen av program. Sedan är det stopp även på den plattformen.

This work is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License.

  • Kör en html-editor med namnet PageSpinner 5.1.2. Programmet har inte uppgraderats sedan 2010 och är ett 32-bitarsprogram. Är jag rökt med det om jag installerar High Sierra? Jag borde ha lämnat det för länge sen i och med att jag prenumererar på Adobe CC 2017 och där ingår DreamWeaver. Skulle ha gått över till det, dumt att betala för något som inte används.

    • Tyvärr, gamla 32-bitars program kommer inte att fungera med High Sierra.

      • Men enligt rubriken är High Sierra sista versionen som stöder 32-bitarsprogram.

        • Hel rätt, nu när jag läser igenom en massa artiklar själv så är det en smula förvirrande. En del skriver att High Sierra är den sista versionen som stöder 32-bitar, andra att High Sierra inte gör det. Så som jag uppfattar det så är High Sierra den sista versionen som stöder 32-bitar.

          • Ja, det får vi hoppas. Jag siktar på att installera High Sierra, trots att datorn är på gränsen att vara för gammal (Mac Pro Quadcore mid 2012). Men jag befarar dock att Nikons bildprogram ViewNX-i inte har stöd för High Sierra än, så om jag installerar upphör nog programmet att fungera trots att det är ett 64-bitarsprogram. Det kom nyligen en uppdatering, men enligt informationen inget High Sierra-stöd.

          • Ok, då förstår jag att frågan/lösningen är viktig men som jag förstått det så dras strecken efter High Sierra.